MMS on Galaxy S6 creates separate conversation thread, other issues

Welcome to another post about #GalaxyS6! Our post today covers 6 issues shared by our community members. Don’t forget to also visit our S6 troubleshooting page for our previously published articles.

  1. MMS on Galaxy S6 creates separate conversation thread
  2. Galaxy S6 does not power on
  3. Galaxy S6 lags and loses battery power fast
  4. Galaxy S6 won’t factory reset under Settings
  5. Galaxy S6 is not recognized by computers
  6. Replacement Galaxy S6 has fast charging feature not working and battery drain issue

If you are looking for solutions to your own #Android issue, you can contact us by using the link provided at the bottom of this page, or you can install our free app from Google Play Store.


Problem #1: MMS on Galaxy S6 creates separate conversation thread

I have a Verizon phone but my carrier is AT&T. Regular SMS text messages, phone calls etc., work. However, when I receive a picture (MMS message) my phone creates a separate text thread for that person as if we are in a group. It will not come through the regular text thread that already exists. For example, I’m sending regular texts to John, John then sends me a picture. I have to go to my conversation list and click on a whole new thread my phone created, and it is now a group conversation message with “Me, John”. If I text back in this new thread in the group, it sends me a separate message just to me as well, but not to the original text messages John and I had while just texting. It is like the messages do not recognize my number as being my phone and sends them to me twice.

All APN options are correct and mobile data is on etc. I’m not using a 3rd party messaging app. I am using the Samsung message program within the phone, which is set as the default messaging service. — Greg

Solution: Hi Greg. Did the issue start to appear after installing an update for Android or your messaging app? If yes, make sure to delete the phone’s cache partition first, then wipe the cache and data of the app involved. Below are the steps that you must do:

How to wipe the cache partition of Galaxy S6 Edge

  • Turn the device off.
  • Press and hold the Power, Volume Up and Home buttons simultaneously.
  • When the phone vibrates, release the Power button but continue to press and hold the Volume Up and Home buttons.
  • Now, when Android recovery screen appears, highlight the wipe cache partition option using Volume Down button.
  • To confirm the selection, press the Power button.
  • Wait for a while until wiping the cache partition is finished.
  • Now, “Reboot System now” will appear on the screen. To highlight the option use the Volume Up/Down key.
  • Press the power button to confirm it, and your device will automatically reboot.

How to delete an app’s cache and data

  • Go to Settings.
  • Proceed to Applications.
  • Select Manage Applications.
  • Tap the All tab.
  • Choose the name of the app by tapping it.
  • From there, you will see the Clear Cache and Clear Data buttons.

If nothing changes after doing these procedures, or if you’ve already done them, the cause of the problem may be firmware-specific. That means that poor coding makes the current operating system work improperly resulting to this erratic behavior. Be sure to get the latest Android software update. You can also try to do a factory reset to see the difference.

Problem #2: Galaxy S6 does not power on

At first it wouldn’t hold a charge. It is not hardware issue. I tried several different charging devices. I believe, the AT&T carrier representative did a hard/soft reset. Returned to factory settings. I don’t know if it completed a software update also. It said something about trying to use an alternative operating system as a selection/option.

I believe I’m at this point of the troubleshooting: Otherwise, I recommend you wipe the cache partition if there’s enough battery left, if not, then you need help from a tech.

I did not have enough battery life to complete the cache partition. The AT&T carrier rep advised I have it sit with the original charger for a few hours and if that does not work, I must warranty it.

After he did the factory reset for a short time after it was showing the charging lighting bolt consistently, but not gaining percentages. Now…. nothing. Please HELP! Pretty Pretty Please. — Stephanie

Solution: Hi Stephanie. The first thing that you can do is to see if your phone still responds to hardware button combinations. Before you do this, make sure that the phone has been charging for at least an hour. The first thing hardware button combination that you can try is to boot the phone in recovery mode. Here’s how it’s done:

  • Turn off your Samsung Galaxy S6 Edge.
  • Press and hold the Volume Up, Home and Power keys together.
  • When the device powers on and displays ‘Power on logo’, release all keys and the Android icon will appear on the screen.
  • Wait until the Android Recovery Screen appears after about 30 seconds.

If your phone can’t boot into recovery mode, try to go to download mode. Using the same steps above, simply press the Volume Down, Home and Power buttons at the same time for at least 10 seconds.

You can also boot in safe mode by doing these steps:

  • Press and hold the Volume Down and Power keys for 20 to 30 seconds.
  • Once you see the Samsung logo, release the Power key immediately but continue pressing the Volume Down key.
  • Your phone should continue booting up and you will be prompted to unlock your phone as usual.
  • You will know if the phone successfully booted in safe mode if the text “Safe mode” is displayed at the lower-left corner of the screen.

If your phone still fails to boot to any of these modes, you can assume that a hardware issue may be at play. Make sure that you have unit checked or replaced.

Problem #3: Galaxy S6 lags and loses battery power fast

I got my S6 like half a year now. And it is really terrible! it is totally slow when i open apps, going back to the home screen or doing anything else. Everything lags!

Another problem i have is that my power is going down very rapidly, so i had to buy a power bank and charge my phone like 2-3 times a day even though i am not using it that much.

Thirdly, it suddenly crashes sometimes. or my music just begins to play without pushing any button.

i tried a hard reset but it didn’t help. Furthermore i try to clear my cache as you have explained it in your article but that didn’t work. when i have reached the second white screen, the screen turned black with a small picture of a mobile phone and inside of it a red triangle with an exclamation mark in it. After like 2 minutes, my phone restarts and I’m coming back to my home screen.

Please help me! it is really awkward having my phone and i don’t have enough money to buy me a new one. — Katharina

Solution: Hi Katharina. There are two potential causes to the issues you mention here — either the phone is infected with a virus or malware, or there are many apps running actively and in the background at the same time. The best thing that you can do first is to do a factory reset. For serious firmware-related issues, the factory reset is often the ultimate fix. It’s because it will bring the phone back to its factory defaults by deleting all files, data, settings, apps, personal information, accounts, etc. Ensure to create a backup of your personal data first before doing the steps below:

  • Turn off your Samsung Galaxy S6 Edge.
  • Press and hold the Volume Up, Home and Power keys together.
  • When the device powers on and displays ‘Power on logo’, release all keys and the Android icon will appear on the screen.
  • Wait until the Android Recovery Screen appears after about 30 seconds.
  • Using the Volume Down key, highlight the option, ‘wipe data/factory reset’ and press the Power key to select it.
  • Press the Volume Down button again until the option ‘Yes — delete all user data’ is highlighted and then press the Power key to select it.
  • After the reset is complete, highlight ‘Reboot system now’ and hit the Power key to restart the phone.

Now, doing a factory reset is, in itself won’t be an effective fix if you will not be careful what apps to install. After the factory reset, be sure not to install least used apps or those applications that may be the reason of the problems. Although it’s tricky to know what app is exactly the cause of the problem, in general, you must get rid of games and downloaders. Least known developers tend to monetize their products by resorting to dubious means which can include allowing viruses, adware, and even malicious software to piggyback on their app so they can get paid. Most developers intentionally publish their apps for monetary gain. If their product can’t get enough audience, they may switch to other suspect means of making money.

If you are fond of installing free apps, it’s time to review them. Stick to official apps if possible and avoid installing new ones if you are not sure where they come from.

Problem #4: Galaxy S6 won’t factory reset under Settings

I’ve been able to factory rest my phone before through SETTINGS but now it annoyingly refuses to hard reset even though I’ve tried many times…all it does is restart the phone.

Also there is this message that I usually get this period which even usually terminates whatever I am doing with the phone: “measure not responding” or “Unfortunately Measure has stopped”. Actually there was a time something was happening which I did not understand and I uninstalled the program called measure thinking it was a Malware that just installed on its own trying to attack my phone and slowing it down. But now it appears that this program is a critical system app (well I don’t really know that for sure yet).

So please what is your diagnosis and help me get my phone back to it factory state. — Anderson

Solution: Hi Anderson. We’re not aware of a critical app for Samsung devices called Measure but it can be a carrier-specific app instead. This may be the reason why the error comes up everytime you do something. If you are not sure of this, be sure that you do a master reset. Simply follow the steps provided on how to do a factory reset above.

Problem #5: Galaxy S6 is not recognized by computers

Hello. I have been having difficulty for the past two weeks attempting to get my phone and computer to cooperate and I was hoping you could help. Prior to two weeks ago I would plug my phone (using its original cable) into my computer and on my phone I would click something to the effect of to share content from my phone via media or camera to my computer. Once I completed that, I was free to interchange music pictures etc.

For the past two weeks when I plug my phone into my computer nothing happens other than my phone begins to charge. What I mean by nothing happens is there is no sounds from either my phone or computer upon plugging in (because I do believe there was a dig of some sorts prior to these two weeks) or unplugging, there is no appearing of any sort of icon on the bottom left icon widget bar on my computer or next to my local C Drive under the folder of MY PC. There is also no option on my phone for choosing which setting to connect to my computer with.

I have tried multiple times over the past two weeks to repeat my previous successful endeavors including restarting both pieces of technology, downloading the USB drivers for my computer and smart switch for my phone. I have tried plugging in another USB into my computer prior and post download of the USB driver and it still works. I have tried plugging in my phone to another computer (a Mac) and it shows USB installer options. I am unaware of how to proceed, if assistance is possible I would very much appreciate it.

Thank you. — Kathryn

Solution: Hi Kathryn. For an issue like this, make sure that you verify the obvious first. Try to connect the phone to your PC again then go over to your phone Settings menu. Once you’re in settings, go to Storage then tap on the more options menu icon at the upper right hand side (three-dot icon) to access USB computer connection option. Under normal circumstances, the Media device (MTP) should be shown. If nothing happens when you press the More menu icon, this means that your computer has a driver problem. Sometimes, a computer’s operating system may encounter USB-related errors especially if you use multiple USB devices (flash drives, keyboard, mouse, cameras, smartphones, etc.) all the time.

With your phone still connected to your PC via USB, navigate to your computer’s Device Manager under Control Panel. If your computer detects your phone but cannot read it properly, your device should be shown as one of the items. Make sure to right click on your device and click on “Update Driver Software”. Follow the rest of the instructions and let your computer look for available drivers online.

You can also try to use third party Windows applications like USBDeview to uninstall unnecessary USB devices. If you don’t want to install any app on your computer, simply go over the list in your Device Manager page and uninstall as many USB devices as possible. Make sure you don’t disconnect peripherals like a USB keyboard or mouse though.

Lastly, don’t forget the good old trick of enabling USB debugging option under Developer options.

Problem #6: Replacement Galaxy S6 has fast charging feature not working and battery drain issue

I saw your article on the Samsung S6 Edge having charging issues. I am now on my SECOND Samsung S6 because my first one wouldn’t not charge at all. I went to my Phone Service Carrier, and they sent me a new phone. My new phone is having the same issues as my first one. I received the fast charger in the box with my first phone, and I use this charger to charge my phone. My phone will not accept the fast charger function anymore. It will still charge but not “fast” (it will not be labeled as “Fast Charging.”). It will still say its “charging,” but I will leave my phone turned off, plugged in for hours waiting for it charge and it will charge about 5% an hour.

My battery drains at about the same rate as before I was having these charging issues, and I haven’t dropped/cracked/damaged my phone externally in anyway. Is there a simple way to fix this, do I just need a new charger, etc. I don’t want to have to spend money if I don’t have to. Thank you. — Gwen

Solution: Hi Gwen. Did you install the same set of apps after getting the replacement phone? If yes, that’s an indication that one of your apps must be causing this trouble. Do a factory reset and observe the phone for at least 24 hours. Make sure you don’t install any app during this period.


Engage with us

If you are one of the users who encounters a problem with your device, let us know. We offer solutions for Android-related problems for free so if you have an issue with your Android device, simply fill in the short questionnaire in this link and we will try to publish our answers in the next posts. We cannot guarantee a quick response so if your issue is time sensitive, please find another way to resolve your problem. 

When describing your issue, please be as detailed as possible so we can easily pinpoint a relevant solution. If you can, kindly include the exact error messages you are getting to give us an idea where to start. If you have already tried some troubleshooting steps before emailing us, make sure to mention them so we can skip them in our answers.

If you find this post helpful, please help us by spreading the word to your friends. TheDroidGuy has social network presence as well so you may want to interact with our community in our Facebook and Google+ pages.

Posts You Might Like

Leave a Comment