Galaxy Note 4 keyboard issue after updating to Lollipop, other issues

NOte 4 keyboard

Although Android Marshmallow has already started to become available to newer devices, a huge number of Samsung Galaxy devices, including the #GalaxyNote4, is still running Lollipop at this time. This post addresses some of the post-Lollipop problems encountered by some Note 4 users as well as other problems not totally related to Android update. Below are the specific issues addressed here today:

  1. Galaxy Note 4 keyboard issue after updating to Lollipop
  2. Galaxy Note 4 sends text message immediately without allowing photo attachment
  3. Galaxy Note 4 won’t boot normally
  4. AT&T Galaxy Note 4 won’t install Lollipop when in Three mobile network
  5. Galaxy Note 4 TouchWiz Home issue after rooting
  6. Galaxy Note 4 from India won’t install update in Australia

If you are looking for solutions to your own #Android issue, you can contact us by using the link provided at the bottom of this page, or you can install our free app from Google Play Store.


Problem #1: Galaxy Note 4 keyboard issue after updating to Lollipop

On 19 Feb 2016 after the latest update to Lollipop 5.1.1 on my Samsung Galaxy Note 4 (Model_SM-N910T_Baseband Version-N910TUVU2DOK2_32GB_T-Mobile) the key-tap “CLICK” sound on the Samsung keyboard stopped, but the vibration works. The key-tap “CLICK” sound/vibration works when selecting the “PREDICTIVE WORDS” only. All the other sounds/vibrations works fine.

This problem started after the latest “UPDATE” to Lollipop 5.1.1.

I have “ENABLED” the key-tap sound in the settings are as follow >>>

SETTINGS > Language and input > Samsung keyboard > key-tap feedback > Sound and Vibration > both “ENABLED”.

SETTINGS > Sounds and Notifications > Other Sounds > Samsung Keyboard > Sound when tapped and Vibrate when tapped > both “ENABLED”.

Please Help Me ??? — Rahiem

Solution: Hi Rahiem. If the issue happens after updating the firmware, wiping the cache partition may help. The system cache stores downloaded items from Play Store and other app-related files in order for the system to load app faster. Every time you tap an app icon on the screen, one of the background processes that happens is the system attempting to access the cache partition to load an app quickly. This process is repeated every day and every time you open an app. After some time, the cache gets full and disorganized so it’s highly recommended to regularly clear the cache partition.

Following an update, there’s a chance that the cache partition will become disorganized, cluttered, or contain outdated and irrelevant files. While updates like Lollipop are supposed to automatically create a new cache, this does not always happen in reality. One of the main reasons why so many users are complaining about slow performance, lag, or freezing issues after updating to Lollipop is a corrupted cache partition. We think that this is also the reason for your case. If you haven’t tried clearing the cache before, here are the steps to do it:

  • Turn off the Galaxy Note 4 completely.
  • Press and hold the Volume Up and the Home keys together, then press and hold the Power key.
  • When the Note 4 vibrates, release both the Home and Power keys but continue holding the Volume Up key.
  • When the Android System Recovery shows on the screen, release the Volume Up key.
  • Using the Volume Down key, highlight the option ‘wipe cache partition’ and press the Power key to select it.
  • When the wiping of the cache partition is finished, highlight Reboot system now and hit the power key.

Now, if wiping the cache won’t help the next best thing to do is to wipe the phone and restore default settings. Here’s how:

  • Turn off the Galaxy Note 4 completely.
  • Press and hold the Volume Up and the Home keys together, then press and hold the Power key.
  • When the Note 4 vibrates, release both the Home and Power keys but continue holding the Volume Up key.
  • When the Android System Recovery shows on the screen, release the Volume Up key.
  • Using the Volume Down key, highlight wipe data / factory reset and press the Power key to select it.
  • Now highlight Yes — delete all user data using the Volume Down key and press the Power key to begin the reset.
  • When the master reset is complete, highlight Reboot system now and hit the Power key.
  • The Note 4 will restart but it will be longer than usual. When it reaches the Home screen, then begin your setup.

Problem #2: Galaxy Note 4 sends text message immediately without allowing photo attachment

Hi! I didn’t see this topic on your blog and I am hoping you can help me with my new Galaxy Note 4 from T-Mobile. When I type a message in the stock text messaging software and then I click attach to attach a picture to be added to the message, the picture will send by itself and not allow me to attach and send the message at the same time with the picture. This may not be a big deal for many people but I am annoyed as hell about this as a person who sends pictures often. So now I have to send the message I type and then send the picture or vice versa send the picture and then send a totally separate text message with the words….it’s STUPID!

I purchased the Note 4 over the Note 5 because the Note 5 had this same issue and I figured this was a feature that started with the Note 5. While I was in T-Mobile we tested the Note 4 with their in-store display and the message and picture attached and were sent together without incident, but I finally get it home and switch over everything only to find out that this phone is now doing the same thing. We even tested the phone before I left the store….ugh can you please help me??? — Diana

Solution: Hi Diana. We noticed this problem with other T-Mobile subscribers several months back and it’s interesting to know that it still exists even up to now. Apparently, the issue is not device related but rather a poor coding glitch for T-Mobile’s Android Lollipop version. At this time, there are only two potential solutions that we know of:

  • turning off voLTE, and
  • doing a factory reset

To disable voLTE, just follow these steps:

  • Tap Phone > Keypad tab.
  • Tap More options > Settings.
  • Tap Call > Voice over LTE settings.
  • Tap Use VoLTE when available or Do not use VoLTE.

Make sure to perform a factory reset (steps provided above) if turning off VoLTE won’t change anything.

Problem #3: Galaxy Note 4 won’t boot normally

Hello. My phone randomly went into ‘memory recover’ with the word Samsung as if it was closing. So when that happened I tried to shut the phone instantly and now my phone would just not open again. It was 15% battery when that happened. I do not think I updated my software – i think it needed updating. I do not know what to do now. I tried holding all the buttons to open it, I tried removing the battery and adding it again, I tried charging the phone (even the sign where it shows the battery should be charging when its off isn’t showing)

Here is some information about my phone: I am not sure what version of software I have since my phone is shut and won’t open. I use Bell as my carrier. I was watching a YouTube video when all this happened. The phone was on flight mode. I have been using the phone a lot. My phone is known to randomly close down an app that was open.

What should I do? Thank you. — Sondous

Solution: Hi Sandous. If your phone won’t boot normally, try booting it in maintenance mode. In this environment (if it loads), you will have an option to either boot in safe mode or recovery mode. Loading maintenance mode also means that the problem may not be hardware-related at all. To boot in maintenance mode, simply press and hold Power and Volume Down buttons for at least 10 seconds.

If the phone still fails to boot this way, consider using another battery or have the phone checked for hardware errors.

Problem #4: AT&T Galaxy Note 4 won’t install Lollipop when in Three mobile network

Hello there. Thank you for taking the time to help me, I truly appreciate it!

I got this Samsung Galaxy Note 4 unlocked brand new, and it came with KitKat 4.4, but the Android Lollipop has since been released but whenever I try to do a software update the following message comes up: “This software update has been interrupted. Try again in 24 hours”.

This phone is unlocked as I am in the UK and using a Three SIM, but it was previously on AT&T but unlocked, so whenever I do a software update it says “AT&T software update”. It doesn’t just have a normal software update.

I don’t know whether this is normal or not, also, I’ve tried updating the software over KIES several times but it says that “i have the latest update” but I know that I do not. I don’t really want to try it over ODIN as I’m scared to brick my phone. If you could please offer me some guidance on how to safely and securely update my phone software.

Thank you! — Joannes

Solution: Hi Joannes. Your phone’s firmware is from AT&T and will only allow an Android update when you are connected to AT&T network. This is the reason why you cannot download and install an over-the-air update outside AT&T network.

If you badly need to update to Android Lollipop, you have no other means but to go via Odin to do it.

Problem #5: Galaxy Note 4 TouchWiz Home issue after rooting

My Samsung Note 4 is displaying “Unfortunately, Touch Wiz Home has stopped” in a loop and the screen turns on and off. The screen is black except for the notification drawer which works.

It started after I rooted the phone with Framaroot and installed System App Safe Remover and removed the non-essential apps. Afterwards, I discovered I was not able to see a SMS message sent to me, so I tried to recover all the apps from the recycle bin from the same app. During this process of restoring the apps to the phone, the phone started to display “Unfortunately, TouchWiz Home has stopped” and the screen had turned dark and kept looping the same words about TouchWiz.

I would like to keep my phone data if possible and so I would prefer not to perform a full restore. If not, can you show me how to restore the phone.

Please advise. Thank you so much. — Cody

Solution: Hi Cody. Please connect your phone to a computer and create a backup of your personal data (photos, videos, contacts, etc) first. Then try to see if wiping the cache partition will help. If that won’t change anything, consider doing a factory reset, or simply restore the stock firmware via Odin.

Problem #6: Galaxy Note 4 from India won’t install update in Australia

I live in Australia and during my recent trip to India, I bought an Android phone. The phone is running Android 5.1 and since I have gotten back to Australia, the phone notifies me that I have an update that I need to install. It downloads the 770MB update and then when I try to install it, it shuts down and restarts the phone and then starts installing the update, I can see the Android mascot. After it gets to about 20% or so, I just get a message saying “Error”. That is all. The Android mascot is lying down or so and from its open belly there is an exclamation icon. At this stage there is no sim card on the phone.

Additionally, some apps like Facebook, Angry Birds or Stick Cricket 2 fail to install. Facebook messenger can be installed. I am a developer and I  would like to get the latest update for my new Android phone, so would appreciate some help with this. Cheers. — Bhuman

Solution: Hi Bhuman. Your issue may be similar to Joannes above. Basically, the firmware running on the phone may be that of a carrier from India so downloading and/or installing an update over-the-air in Australia will most likely fail. That doesn’t explain much though why you are also unable to install other apps like the ones you mention above.

We know from experience that some knock offs may refuse installation of official apps, or won’t even open Google Play Store. We can’t see no reason for a genuine Galaxy Note 4 not to allow installation of the apps mentioned here. Try to call Samsung and check if the IMEI on your phone shows you have a genuine device or not.


Engage with us

If you are one of the users who encounters a problem with your device, let us know. We offer solutions for Android-related problems for free so if you have an issue with your Android device, simply fill in the short questionnaire in this link and we will try to publish our answers in the next posts. We cannot guarantee a quick response so if your issue is time sensitive, please find another way to resolve your problem. 

When describing your issue, please be as detailed as possible so we can easily pinpoint a relevant solution. If you can, kindly include the exact error messages you are getting to give us an idea where to start. If you have already tried some troubleshooting steps before emailing us, make sure to mention them so we can skip them in our answers.

If you find this post helpful, please help us by spreading the word to your friends. TheDroidGuy has social network presence as well so you may want to interact with our community in our Facebook and Google+ pages.