, ,

Samsung’s adblock toting browser now compatible with older Galaxy devices

Samsung Internet Browser

The Samsung Internet 4.0 app is now compatible with devices that are running Android 5.0 Lollipop as well. This is major news as the browser was only supported by Samsung’s Marshmallow smartphones/tablets before. This update brings support for older devices like the Galaxy S4, Galaxy S4 Active, Galaxy S5 and so on. Basically, if you have a Samsung Galaxy handset that’s running the company’s official Android ROM, then the Samsung Internet 4.0 app should be compatible with your device.

One of the benefits of having this app installed on your device is that it lets you block out annoying advertisements that might pop up during browsing. This is all thanks to adblocking which is integrated within the browser. It will be interesting to see if Google will have anything to say about this as Adblock apps have significantly eaten into Google’s ad revenue. Google even removed the Adblock app from the Play Store, only to have it back after widespread public ire.

Unfortunately, Samsung Internet 4.0 is an exclusive to the company’s Galaxy devices, so non-Samsung device owners won’t be able to take the browser for a spin. But if you have a compatible device, make sure you hit the Play Store link below to download the app on your smartphone.

Source: Google Play Store

Via: Pocketnow